开发者 tihmstar 按照之前的承诺,在新年之前发布了 iOS 降级工具 Prometheus。Prometheus 允许用户将 iOS 设备降级或者升级到已经停止验证的 iOS 版本。要知道,苹果每次发布一个新的固件版本后不久,就会关闭旧版本的固件验证,用户升级之后也就不能回到更早的版本了。Prometheus就是为了打破这样的限制的。

据 tihmstar 介绍,Prometheus 基于 nonceenabler、futurerestore、imgtool 和 GUI 这些本身就具备升级或降级功能的工具。当然,Prometheus 并不是万能的,也有一定的条件,一起来看看:

  1. Prometheus 只支持64位设备。这意味着 iPhone 4s这样的老机子并不支持。
  2. 大部分情况下,当前使用的固件版本需要越狱。如果在 iPhone 5s 和 iPad Air 使用 nonce collision,则不需要越狱。
  3. 如果在越狱的设备使用 Prometheus 降级,则要求越狱的设备必须有tfp0或者host_get_special_port功能。可喜的是,目前的盘古 iOS 9.1和 JailbreakMe for 9.3.3 以及最新的 Yalu iOS 10.(1(.1) 越狱都有这个功能。不过 JailbreakMe 是不完美越狱,而降级过程是需要重启的(重启会导致不完美越狱失效),所以还不确定是否可用。
  4. 想要升级或降级到其他固件版本,无论是否越狱,都必须有通过 tsschecker 保存的 shsh2 文件,早期的 shsh 是不行的。

所以,你的设备满足以上条件了吗?

tihmstar提供了一个视频,感兴趣的可以尝试下(原始视频地址及工具下载戳这里):